Problems with the LED Lantern Posts?

User avatar
jchunick
Minotaur Lord
Minotaur Lord
Posts: 3062
Joined: Mon Nov 11, 2013 6:49 pm
Location: Thunder Bay
Contact:

Re: Problems with the LED Lantern Posts?

Post by jchunick » Sun Aug 20, 2017 4:41 pm

dice4hire wrote:
Sun Aug 20, 2017 4:04 pm
I think if I get any more LED socket items I will be supergluing around the sockets ASAP, maybe that will help the problems.

Call to DF, if possible, can you make LEDS one piece to avoid this, I do not think switching LEDs is worth them breaking. I know in some places it might be needed, but I see the one piece braziers, LED floors and tavern tables working fine when my friend is having trouble with his arcane orbs.
They couldn't be made one piece, but I think a design that will fix this issue will be a mounting for the socket.
Unless otherwise noted, my views and opinions on this forum are my own and do not, in any way, reflect the views and opinions of Dwarven Forge.

User avatar
dice4hire
Minotaur Lord
Minotaur Lord
Posts: 2473
Joined: Thu May 02, 2013 7:13 pm
Location: Nagoya Japan

Re: Problems with the LED Lantern Posts?

Post by dice4hire » Sun Aug 20, 2017 4:04 pm

I think if I get any more LED socket items I will be supergluing around the sockets ASAP, maybe that will help the problems.

Call to DF, if possible, can you make LEDS one piece to avoid this, I do not think switching LEDs is worth them breaking. I know in some places it might be needed, but I see the one piece braziers, LED floors and tavern tables working fine when my friend is having trouble with his arcane orbs.
A pretty decent Docent of Valoria

User avatar
HeroQuestFrance
Ogre
Ogre
Posts: 924
Joined: Wed Dec 28, 2011 4:02 am

Re: Problems with the LED Lantern Posts?

Post by HeroQuestFrance » Sun Aug 20, 2017 2:17 pm

Got mines : 4 on 4 are out of work .... so sad !

User avatar
Arcarius2001
Minotaur
Minotaur
Posts: 1556
Joined: Wed May 04, 2011 11:32 am
Location: California

Re: Problems with the LED Lantern Posts?

Post by Arcarius2001 » Wed Aug 09, 2017 9:53 am

I received a set of lantern posts this week. 3 were ok but the other one had to be fixed. I would have had no idea how to do that without patransom's posts. Thanks again!
(And it's definitely advantageous to have a young daughter who likes beading.)

Heresy
Goblin
Goblin
Posts: 34
Joined: Sun Sep 25, 2016 8:30 pm

Re: Problems with the LED Lantern Posts?

Post by Heresy » Tue Aug 01, 2017 10:39 pm

Thr first one out of the box had this issue and I had to take it apart (which was a PITA) to fix it. So the rest of them I preemptively used a toothpick and gel superglue to glue the socket into place. So far they have all stayed in place and while tedious it was a lot easier than taking the posts apart.

I also had 3 of the socket bases with issues, 2 were the glue not holding the socket in place but, fortunately, these are simple to repair. The other one the red wire from the LED was not connected to the switch, kind of a pain to get the glue blob off of the connections to fix but not terrible.

I hope DF is talking to the factory about these issues\quality control for DoD.

patransom
Goblin
Goblin
Posts: 38
Joined: Wed Mar 23, 2016 8:10 am

Re: Problems with the LED Lantern Posts?

Post by patransom » Sat Jul 29, 2017 12:39 pm

Arcarius2001 wrote:
Fri Jul 28, 2017 9:43 am
Thanks, patransom, for those pics and tutorial. I have been hesitant to get the lantern posts due to this problem. Your fix seems easy enough for me to pull the trigger on them. Thanks again!
You're welcome! But I wouldn't necessarily call the fix "easy." Maybe more like moderate. Some pillars are stuck together better than others and require careful work with a sharp tool (see the new picture I posted) to open up without damaging them. You also want to be careful with the glue to avoid getting it in the socket holes. I've managed to avoid both problems so far, but I've been spending 30-40 minutes on each pillar, being careful.

patransom
Goblin
Goblin
Posts: 38
Joined: Wed Mar 23, 2016 8:10 am

Re: Problems with the LED Lantern Posts?

Post by patransom » Sat Jul 29, 2017 12:33 pm

One more picture from my ongoing lantern post repair project. On this pillar, I took the whole half off for better access. The picture shows how there's plenty of support for the switch and its blob of glue. If only they'd designed it with a similar diagonal bit behind the socket, maybe it wouldn't have ended up hanging loose like it is in the picture.

Image

pacarat
Ogre
Ogre
Posts: 755
Joined: Fri Oct 03, 2014 11:13 am

Re: Problems with the LED Lantern Posts?

Post by pacarat » Fri Jul 28, 2017 10:32 am

Shame they couldn't figure out where the stresses would be located and plan accordingly. Two of my eight were bad out of the box - just a matter of time before the rest go, based on those internal pics.

User avatar
Arcarius2001
Minotaur
Minotaur
Posts: 1556
Joined: Wed May 04, 2011 11:32 am
Location: California

Re: Problems with the LED Lantern Posts?

Post by Arcarius2001 » Fri Jul 28, 2017 9:43 am

Thanks, patransom, for those pics and tutorial. I have been hesitant to get the lantern posts due to this problem. Your fix seems easy enough for me to pull the trigger on them. Thanks again!

patransom
Goblin
Goblin
Posts: 38
Joined: Wed Mar 23, 2016 8:10 am

Re: Problems with the LED Lantern Posts?

Post by patransom » Thu Jul 27, 2017 10:17 pm

oddbender wrote:
Thu Jul 27, 2017 10:08 pm
I upload my pictures to Imgur.com, select the picture once uploaded, and then copy the code from the "BBCode" option and paste it here. I works great.
Thanks! Images fixed.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests