Please help with our research on posts with broken image icons

User avatar
ObLaDi
Site Admin
Site Admin
Posts: 83
Joined: Mon Jan 12, 2015 4:23 pm

Re: Please help with our research on posts with broken image icons

Post by ObLaDi » Mon Nov 02, 2015 4:57 pm

Hi, folks, there seem to be a few layers of mysteries with regard to the broken images. I'm resolving them one at a time.

Some sad news - unfortunately, it seems that there ARE some missing image files. I'm a little unclear as to the history of the updates to the Forum, but I am finding that these stem from about the 2012 era. In some cases, I've found images on the old server and have uploaded them to our current Forum server. However, there are a number of image files that are indeed completely missing.

There is an update that I will apply to the database in the next few days when I get the OK from Jay, and that will resolve some of the more recent image issues and some of those half-baked image tags that aren't actually images, but look like broken images.

I appreciate all the input you all have provided.

User avatar
William
Minotaur Lord
Minotaur Lord
Posts: 2165
Joined: Tue Mar 16, 2010 6:59 am
Location: Kent, WA
Contact:

Re: Please help with our research on posts with broken image icons

Post by William » Thu Oct 29, 2015 12:52 pm

If you need a few more threads/posts to do your testing on, I sent Johanna a huge list of them months ago that needed repairing. She might still have those emails. Some were mine, but since I fixed all of mine they don't need repairing. Listed in those emails were many from other forumites too, picture threads that I remember were awesome. Hope this gets fixed, some newbies have missed some great pictures.
Sir William of the Basalt Region of Mythras
( aka: Rock Breaker Bill - Column Barron of BRoM )

User avatar
ObLaDi
Site Admin
Site Admin
Posts: 83
Joined: Mon Jan 12, 2015 4:23 pm

Re: Please help with our research on posts with broken image icons

Post by ObLaDi » Thu Oct 29, 2015 11:40 am

Thanks, Josh. You're always so generously helpful. I think I have it covered - I can write code and I know both the systems.

User avatar
jchunick
Minotaur Lord
Minotaur Lord
Posts: 3068
Joined: Mon Nov 11, 2013 6:49 pm
Location: Thunder Bay
Contact:

Re: Please help with our research on posts with broken image icons

Post by jchunick » Thu Oct 29, 2015 11:17 am

I might be able to write some code to repair it en masse, but I would need some specific details... maybe we can make a project out of this with Jay's approval.
Last edited by jchunick on Thu Oct 29, 2015 12:10 pm, edited 1 time in total.
If you aren't gaming then you aren't living.

User avatar
ObLaDi
Site Admin
Site Admin
Posts: 83
Joined: Mon Jan 12, 2015 4:23 pm

Re: Please help with our research on posts with broken image icons

Post by ObLaDi » Thu Oct 29, 2015 11:13 am

Hi, Josh, the old Forum was version 1.5.26 of Joomla. Yeah, Joomla's up to 3.4.5 now.

User avatar
ObLaDi
Site Admin
Site Admin
Posts: 83
Joined: Mon Jan 12, 2015 4:23 pm

Re: Please help with our research on posts with broken image icons

Post by ObLaDi » Thu Oct 29, 2015 11:08 am

Thanks, William. Happily, all the old images are on the server. It's the links that need to be repaired. I'm not going to be able to correct them all if an en masse repair is not possible, but I will get the most important ones that are pointed out to me repaired. Thanks for all your help.

User avatar
William
Minotaur Lord
Minotaur Lord
Posts: 2165
Joined: Tue Mar 16, 2010 6:59 am
Location: Kent, WA
Contact:

Re: Please help with our research on posts with broken image icons

Post by William » Thu Oct 29, 2015 3:45 am

So, :o I had Feymous' pictures from that post I mentioned earlier and I uploaded to my Imgur account. The pictures are too big to post here unless resized and I didn't want to do that to them. The 10 here correspond to the single post in that thread. I have the 12 other pictures in that thread that are botched. There are newer pictures (showing just fine) in that thread that must have been posted after the re-do of forum.

Open each individually to save off best resolution, but then they will need to be shrunk to fit new forum specs.

http://imgur.com/a/7GA9r

Feymous' picrures from this post-

http://dwarvenforge.com/forum/viewtopic ... 129#p66129

Let me know if you want the other 12. :)
Sir William of the Basalt Region of Mythras
( aka: Rock Breaker Bill - Column Barron of BRoM )

User avatar
jchunick
Minotaur Lord
Minotaur Lord
Posts: 3068
Joined: Mon Nov 11, 2013 6:49 pm
Location: Thunder Bay
Contact:

Re: Please help with our research on posts with broken image icons

Post by jchunick » Wed Oct 28, 2015 6:15 pm

Here is a thread that has a bunch of broken images:
http://dwarvenforge.com/forum/viewtopic ... =20#p64276

It looks like the images are loaded by file.php with the querystring set to an id value, for example:

Code: Select all

<img src="./download/file.php?id=7615" class="postimage" alt="keebler_chests.jpg" onclick="viewableArea(this);">
Now, I know you're using a newer version of phpBB based off the last conversation we had. I checked github to see what code file.php contains for loading the file ( https://github.com/phpbb/area51-phpbb3/ ... d/file.php ) and the 'attach_id' is what's set in the querystring. There's a table in the phpBB that contains information for all the images uploaded as attachments to posts. The table has a lot of fileds and includes the table field, 'attach_id'. I would imagine that those broken images are not properly referenced in the database. What tools were used to import the old forums?... the tool obviously didn't import and preserve the image attachments properly. It should also be mentioned that file.php handles various file (mime) types in a safe and secure way by simply hashing all the files so that no malicious scripts can be 'attached' and executed. So, any tools that were used to import the old forum would necessarily have to properly add the image attachments to the database table and link them to the hashed image files in the /files folder.
If you aren't gaming then you aren't living.

User avatar
LordDust
Minotaur
Minotaur
Posts: 1368
Joined: Sun Mar 31, 2013 10:40 pm
Location: Indiana

Re: Please help with our research on posts with broken image icons

Post by LordDust » Wed Oct 28, 2015 5:40 pm

I just wanted to drop in to thank everyone involved. This archive is a huge resource for the community and having as much of it restored as possible is greatly appreciated!

User avatar
biowizard
Minotaur
Minotaur
Posts: 1544
Joined: Sun Dec 30, 2012 9:24 pm
Location: Montreal, Canada

Re: Please help with our research on posts with broken image icons

Post by biowizard » Wed Oct 28, 2015 4:32 pm

As communicated by email...
(This is absolutely not an exhaustive list, very biowizard-centric...)

These threads had images in them which disappeared after the update.
Users like me and others took the time to re-upload the images to "fix" them manually.

viewtopic.php?f=22&t=6224
viewtopic.php?f=22&t=4477&p=77983&hilit ... and#p77983
viewtopic.php?f=13&t=6033
viewtopic.php?f=13&t=5996&start=10
viewtopic.php?f=13&t=6087
viewtopic.php?f=32&t=5600

These threads have not manually been fixed:

viewtopic.php?f=13&t=6233
viewtopic.php?f=31&t=2547&p=64808#p64808
viewtopic.php?f=31&t=4695&p=62865#p62865
viewtopic.php?f=31&t=6144
viewtopic.php?f=31&t=6166
viewtopic.php?f=13&t=5597&hilit=tree

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests